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Preface 

 
 
The purpose of this booklet is to provide an 
introduction to Microsoft Excel. This text was 
originally written for Excel 2013. There have 
been some cosmetic and feature updates to Excel, 
but the basics remain the same.  
 
After many years with the same interface (e.g., 
Excel 2003, Fig. 1a), Microsoft changed the 
appearance of its Office Suite (e.g., Excel 2007, 
Fig. 1b). The traditional Menus at the top of the 
program window were replaced by a Microsoft 
Office Button and Ribbon interface. With Excel 
2010, the button was replaced with the File tab. 
 
The intent of this course (ENGR 124) is to 
provide you with what I call guided 
exploration of Excel. You will be provided with 
information, tools and hints to use Excel. Then, 
you will use Excel to perform various tasks that 
might be found in the fields of science and 
engineering. These exercises (problems) 
primarily use Excel to perform calculations and 
analyze data, and to create plots. You may learn 
(relearn) some mathematics along the way. 
 
In terms of mathematics, I am assuming that you 
have completed Calculus 1 (derivatives). 
Numerical differentiation and integration are 
the last topics of this course. Some mathematical 
concepts are explained in more detail (e.g., 
logarithmic scales), than those you should be 
familiar with (e.g., the quadratic formula). 
 
The science and engineering principles behind 
the mathematics used in this course are either 
briefly explained in class or on the assignment 
sheets, or are secondary to the exercise (i.e., 
simply take the data as given and plot it); you 
will be given (non-trivial) equations; and then 
need to implement them in Excel. 
 

Generally, for each exercise you will have some 
goal/objective to meet (e.g., solve an equation, 
create a plot). I usually do not give step-by-step 
instructions on how to use Excel to do a 
particular exercise, as part of the process is 
problem solving and exploring. However, do 
not bang your head against the wall for too long; 
do not be afraid to ask for help (hints) from the 
instructor.  
 
Do not be afraid to use Help located at the upper 
right of the Excel Window – or its keyboard 
shortcut [F1] – to look up a command or function, 
etc. Other used references are this brief booklet 
(e.g., formulas and functions in Chapter 3), books 
on Excel, and the many internet resources. 
 
I have grouped the exercises/assignments into 
“modules.” Each module has one, two or three 
topics. Typically, students are able to complete 
the modules well within the semester. However, 
one must consistently work at it each week – at 
least 1.5 to 2 (focused) hours per week. Do not put 
the work off.  
 
CAUTION! Your goal is to become more 
familiar with Excel. If all you are doing is 
trying to complete the modules as fast as possible 
to satisfy the requirements of the course, you are 
probably not retaining much. You should be able 
to use (at least know where to start) the concepts 
of each module after the course is over. Learn. 
 
Finally, this booklet/course is not meant to be a 
complete manual/survey of Excel. There are 
many Excel features that are beyond the scope of 
this course. I recommend that you explore these 
features. Becoming an expert in Excel will serve 
you well in the future.  
 
 
Dom  Dal Bello 
Santa Maria, California 
Fall 2020 
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1.0 Introduction 
 

 
Excel is a spreadsheet program originally 
developed for business applications. Before 
computers, accountants used large paper 
spreadsheets to analyze financial information. 
When a number early in the spreadsheet would 
change, then the rest of the spreadsheet would 
need to be recalculated by hand. Computer 
applications such as Excel allowed those many 
calculations to be automated, reducing time and 
the potential for error. 
 
But Excel is also very useful in science and 
engineering fields. Among other uses, Excel: 
 
 is a powerful calculation tool,  
 can create publication-ready graphs, and  
 can be used as a database. 

 
When you open Excel, the entire program 
window is called the Workspace (Figs. 1 and 2).  
 
Figs. 1a and 1b show the workspace for Excel 
2003 and Excel 2007 respectfully, and Figs. 2a, 
2b and 2c show the workspace for Excel 2010, 
2013, and Excel 365 (the subscription version of 
Excel 2019). Details have changed, but the 
overall look has remained fairly constant. 
 
Excel’s spreadsheet area – called a worksheet – 
is divided into columns (lettered) and rows 
(numbered), similar to an accountant’s ledger or 
a data table. Each cell is identified by its lettered 
column (A, B, etc.) and its numbered row (1, 2, 
etc.). The address of a cell is given by its column 
and row; e.g., the active cell (selected cell) in 
Figs. 1 and 2 is B5. 
 
The default worksheet names are Sheet1, Sheet2 
and Sheet3, etc. A worksheet can be renamed to 
something more identifiable by RIGHT-
CLICKING on the sheet’s tab at the bottom of the 
worksheet, and selecting Rename. 
 

An Excel file – called a workbook – consists of 
one or more worksheets. The default workbook 
name is Book1. The extensions are .xls (Excel 
2003) and .xlsx (Excel 2007, 2010, 2013, 2016, 
2019 ~ Excel 365). 
 
In Excel 2003, a worksheet could have up to 255 
columns and 65,536 rows; there could be up to 
255 worksheets in a single workbook. That’s over 
16 million cells in a worksheet, and over 4 billion 
cells in the workbook! Since Excel 2007 through 
Excel 2013, there can be 16,384 columns and 
1,048,576 rows – over 17 billion cells – in a single 
worksheet. The number of worksheets in a 
workbook is limited only by the computer’s 
memory (or your ability to keep everything 
organized in your mind).  
 
The worksheet may be navigated with the mouse 
curser/pointer (by clicking on cells, or by click-
and-dragging to select several cells), or with the 
Arrow Keys on the keyboard. 
 
 
 

1.1 Navigation Nomenclature 
 
In class, or in this booklet, you may hear/read the 
following phrases shown in CAPITAL letters. 
These phrases indicate how to navigate in Excel. 
 

CLICK  (LEFT CLICK) 
point with the mouse to a cell (or object), 
and click the left mouse-button (if a Mac, 
there is only one mouse button). This 
action will select the cell or the object. 

 
DOUBLE-CLICK 

point with the mouse to the indicated 
object and click twice, quickly. 

 
RIGHT-CLICK 

pressing the right button on the mouse in 
Windows will bring up a shortcut menu 
with common commands based on the 
currently selected object.
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Chart Wizard 

Range F6:H6 

Range F12:H15 

Range 
D10:D1

4

Workbook (file) name 

Name Box (Cell Address) 
Formula Bar 

Toolbars 

Fill Handle 

Worksheet Tabs; a book 
can have several sheets. 

Active Cell 

Top Menus 

Fig. 1a. A typical Excel 2003 Workspace. The default Workbook (file) name is Book1.xls. Each 
Workbook contains several Worksheets (spreadsheets). 

The Active Cell (Selected Cell) is B5. The address or name of the active cell is displayed to 
the left of the Formula Bar. The active cell has a thick border, with a Fill Handle at its lower 
right; the Column (B) and Row (5) Titles (Headings) are highlighted. 

The Formula Bar displays the contents of the active cell, which in this case is a formula:   
 = A5*3   ... meaning take the value in A5 and multiply it by 3. 

A Range is a set of cells that are grouped together. The cells D10, D11, D12, D13, D14 can be 
written as a range, D10:D14; this short-hand notation to indicate a group of cells is very useful. 

The Toolbars (the palettes of graphical menu items just below the Top Menu) can be 
customized. You may customize your toolbars to include the menu commands that you most 
often use. To do so: SELECT MENU Tools/Customize/Commands and drag the appropriate 
command button onto a toolbar.  
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Fig. 1b. A typical Excel 2007 Worksheet. The default Workbook (file) name is Book1.xlsx. Each 
Workbook contains several Worksheets (spreadsheets). 

The Active Cell (Selected Cell) is B5. The address or name of the active cell is displayed to the 
left of the Formula Bar. The active cell has a thick border, with a Fill Handle at its lower right; 
the Column (B) and Row (5) Titles (Headings) are highlighted. 

The Formula Bar displays the contents of the active cell, which in this case is a formula:   
 = A5*3   ... meaning take the value in A5 and multiply it by 3. 

A Range is a set of cells that are grouped together. The cells D10, D11, D12, D13, D14 can be 
written as a range, D10:D14; this short-hand notation to indicate a group of cells is very useful. 

The Quick Access Toolbar can be customized to display Excel commands and features that you 
commonly use. The default commands are Save, Undo and Redo.  

The Ribbon has seven default Tabs that group like tools together. The Home Tab includes the 
following Groups: Clipboard (Cut/Copy/Paste tools), Font, Alignment, Number (Formatting), 
(Table) Styles, Cell (Properties) and Editing tools. The Ribbon can be minimized to show only the 
Tab titles (one of the selections in the drop down menu at the right of the Quick Access Toolbar). 
Other Tabs may appear as appropriate, e.g., a Drawing Tools/Format Tab appears when working 
with graphics. 

Range F6:H6 

Range F12:H15 

Range 
D10:D14 Workbook (file) 

Name 

Formula Bar 

Home Tab

Fill Handle

Worksheet Tabs; a book 
can have several sheets. 

Active Cell 

Title Bar 
Microsoft Office Button 

Zoom Control 

Quick Access Toolbar 
Window Control Buttons 

Workbook 
Control Buttons 

Tabs 

Status Indicator Status Bar View Selector 

Create New Worksheet Tab 

Name Box (Cell Address) 

Help 

Cells Group 
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Fig. 2a. A typical Excel 2010 Worksheet. The default Workbook (file) name is Book1.xlsx. Each 
Workbook contains several Worksheets (spreadsheets). 

The Active Cell (Selected Cell) is B5. The address or name of the active cell is displayed to the 
left of the Formula Bar. The active cell has a thick border, with a Fill Handle at its lower right; 
the Column (B) and Row (5) Titles (Headings) are highlighted. 

The Formula Bar displays the contents of the active cell, which in this case is a formula:   
 = A5*3   ... meaning take the value in A5 and multiply it by 3. 

A Range is a set of cells that are grouped together. The cells D10, D11, D12, D13, D14 can be 
written as a range, D10:D14; this short-hand notation to indicate a group of cells is very useful. 

The Quick Access Toolbar can be customized to display Excel commands and features that you 
commonly use. The default commands are Save, Undo and Redo.  

The Ribbon has seven default Tabs that group like tools together. The Home Tab includes the 
following Groups: Clipboard (Cut/Copy/Paste tools), Font, Alignment, Number (Formatting), 
(Table) Styles, Cell (Properties) and Editing tools. The Ribbon can be minimized to show only the 
Tab titles (one of the selections in the drop down menu at the right of the Quick Access Toolbar). 
Other Tabs may appear as appropriate, e.g., a Drawing Tools/Format Tab appears when working 
with graphics. The File Tab replaced the Microsoft Office Button from Excel 2007. 
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Fig. 2b. A typical Excel 2013 Worksheet. The default Workbook (file) name is Book1.xlsx. Each 
Workbook can contain several Worksheets (spreadsheets). 

The Active Cell (Selected Cell) is B5. The address or name of the active cell is displayed to the 
left of the Formula Bar. The active cell has a thick border, with a Fill Handle at its lower right; 
the Column (B) and Row (5) Titles (Headings) are highlighted. 

The Formula Bar displays the contents of the active cell, which in this case is a formula:   
 = A5*3   ... meaning take the value in A5 and multiply it by 3. 

A Range is a set of cells that are grouped together. The cells D10, D11, D12, D13, D14 can be 
written as a range, D10:D14; this short-hand notation to indicate a group of cells is very useful. 

The Quick Access Toolbar can be customized to display Excel commands and features that you 
commonly use. The default commands are Save, Undo and Redo.  

The Ribbon has seven default Tabs that group like tools together. The Home Tab includes the 
following Groups: Clipboard (Cut/Copy/Paste tools), Font, Alignment, Number (Formatting), 
(Table) Styles, Cell (Properties) and Editing tools. The Ribbon can be minimized to show only the 
Tab titles (one of the selections in the drop down menu at the right of the Quick Access Toolbar). 
Other Tabs may appear as appropriate, e.g., a Drawing Tools/Format Tab appears when working 
with graphics. 
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Fig. 2c. A typical Excel 365 (Excel 2019) Worksheet. The default Workbook (file) name is 
Book1.xlsx. Each Workbook can contain several Worksheets (spreadsheets). 

The Active Cell (Selected Cell) is B5. The address or name of the active cell is displayed to the 
left of the Formula Bar. The active cell has a thick border, with a Fill Handle at its lower right; 
the Column (B) and Row (5) Titles (Headings) are highlighted. 

The Formula Bar displays the contents of the active cell, which in this case is a formula:   
 = A5*3   ... meaning take the value in A5 and multiply it by 3. 

A Range is a set of cells that are grouped together. The cells D10, D11, D12, D13, D14 can be 
written as a range, D10:D14; this short-hand notation to indicate a group of cells is very useful. 

The Quick Access Toolbar can be customized to display Excel commands and features that you 
commonly use. The default commands are Save, Undo and Redo.  

The Ribbon has seven default Tabs that group like tools together. The Home Tab includes the 
following Groups: Clipboard (Cut/Copy/Paste tools), Font, Alignment, Number (Formatting), 
(Table) Styles, Cell (Properties) and Editing tools. The Ribbon can be minimized to show only the 
Tab titles (one of the selections in the drop down menu at the right of the Quick Access Toolbar). 
Other Tabs may appear as appropriate, e.g., a Drawing Tools/Format Tab appears when working 
with graphics. 
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SELECT cell 

CLICK on a specific cell; e.g.: SELECT B5. 
 
CLICK-AND-DRAG, or SELECT range 

point with the mouse (to a cell), click and 
hold the mouse button down, scroll with 
mouse to the cell location where you want 
to end your selection and release the 
mouse button. This action selects a range 
of cells. 
e.g.: SELECT B5:D12. 
The same result is also achieved by 
CLICKING B5, holding down the 
[SHIFT] key, and then CLICKING on 
D12. 

 
SELECT _____ Menu (Excel 2003) 

point with the mouse to the desired menu 
at the top of the Excel window 
(workspace), hold the mouse button down, 
scroll down to the desired menu item on 
the drop-down menu, release the button. 
e.g.: SELECT MENU/INSERT. 

 
SELECT _____ Tab (Excel 2007 onward) 

CLICK the desired TAB in the Ribbon at 
the top of Excel window (workspace) 
e.g.: SELECT INSERT Tab. 

 
CONTROL-CLICK on various cells. 

pressing the [CONTROL] key while 
selecting various cells selects each cell 
individually, adding each individual 
selection to the total group. The cells do 
not need to be adjacent to each other. The 
selected cells are grouped so that they can 
all be formatted, copied, etc. at the same 
time.  

 
 
 
 

1.2  EXCEL Interface 
 
The overall layout – workspace – of 
Excel 2003 and Excel 2007 are shown in 
Figs. 1a and 1b, and of Excel 2010, Excel 2013 
and Excel 2019/365 are shown in Figs. 2a, 2b 
and 2c respectively. 
 
 
 
 

1.3  Cells and their Contents 
 
A cell address – its column and row position – 
is given by its letter column (A, B, … Y, Z, AA, AB, 
AC…), and its numerical row (1, 2, 3, … 26, 27, 
28…). Thus, Cell B5 is in the second (B) column 
and in the fifth row (5). The 27th column is AA, 
followed by AB, etc. 
 
A cell’s address can be thought of as a variable 
name. The content of the cell is the value of the 
variable. Some types of content that can be 
entered in a cell are: 

1. Text, e.g., Monday, Debits, Force. 
In Figs. 1 and 2, n and nx3 are text. 

2. Numbers, e.g., 23, $32, 14.26, 22-Oct-99, 
2.45E+05, 2.45E−05. 
In Figs. 1 and 2, the value of cell A6 is 3. 

3. Formulas define the value of a cell in 
terms of the values of other cells. A formula 
is always preceded by an equal sign, and 
may include numbers, mathematical 
operators (+, −, *, /, etc.) and functions 
(sine, cosine, summation, etc.). For 
example: 

 = A5*3  
means take the number in A5 and 
multiply it by 3, as in Figs. 1 and 2. 

 = A1+B1−C2/3  
add A1 and B1, and then subtract  
one-third of C2.  

 = A1*C3*SIN(B2)  
A1 multiplied by C3 multiplied 
sin(B2); the angle in trigonometric 
functions must be in radians. 

 = SUM(A1:A5)  
sum of the contents of A1, A2, A3, A4, 
A5; i.e., the range is A1:A5. 

 
When a cell is selected (CLICK on the cell), it is 
the Active Cell (or Selected Cell). The active 
cell’s content – text, number or formula – is 
displayed in the Formula Bar. The value (text 
or number) of the cell is still displayed in the cell 
itself.  
 
The selected or active cell has a thick border, 
with a Fill Handle at its lower right (cell B5 in 
Figs. 1 and 2). The cell’s address is displayed to 
the left of the Formula Bar. The cell’s column and 
row headings are also highlighted – the column 
heading (B) at the top of the worksheet, and the 
row heading (5) at the left. 
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With a cell selected, if you then CLICK in the 
Formula Bar, the formula becomes color-coded. 
Each cell address in the formula, and the border 
of the referenced cell, is shown in the same color. 
The color-coding helps the user visualize how the 
cells in the worksheet are related. 
 
Also, if you DOUBLE-CLICK the cell, any 
formula in the cell will be displayed in the cell 
itself and color-coded. 
 
 
 

1.4  Entering Contents 
 
To enter a text string, number or formula into 
a cell, SELECT the cell (with the mouse).  
 
Type the entry and then hit [ENTER] when you 
are done. What you type appears in the cell and 
in the Formula Bar. Hitting the [ENTER] key 
ends the entry; the cursor will automatically 
move down one cell. 
 
You should be aware of the following: 
 a numerical entry is considered as a 

number by Excel; numbers are by default 
right-justified. 

 to enter a number as text, type the single 
quotation mark first, e.g.: '2  ... the number 
will be made a text value (although it can 
still be used as a number); text is by 
default left-justified. 

 always enter an equal sign before any  
formula. 

 any entry that contains a non-number is 
considered text. Exceptions are:  
- when the entry is proceeded by an equal 

sign (then it is a formula), or  
- if it is in scientific notation (e.g., 

2.45E+05, which a computer reads as 
2.45×105). 

 
To edit the contents of a cell, CLICK on the cell, 
and then CLICK on the Formula Bar. 
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2.0  Tab Interface 

 

 
The major change in the Microsoft Office Suite 
from Office 2003 to Office 2007/2010/2013 is 
that the Ribbon interface (Figs. 1b, 2) replaced 
the Menu interface (Fig. 1a). This change made 
the application features easier to access, instead 
of being buried in menus.  
 
 

2.1  Microsoft File Tab  
 
With Excel 2010, the File Tab replaced the 

Office Button  of Excel 2007, which itself 
had replaced the File Menu of Excel 2003. 
Clicking on the File Tab opens the menu shown 
in Fig. 3. 
 
Besides the standard commands used for files, 
the Excel Options (at the bottom of the menu in 
Fig. 3), is used to customize the look of Excel, or 
to activate Add-Ins such as the data analysis 
tool Analysis ToolPak, and the Solver tool, 
both of which are discussed later in this 
text/course.

 

Fig. 3. Excel 2013 File Tab.  (Excel 2010). 
 

 
 

2.2  Ribbon and Tabs 
 
The Ribbon is the primary method of accessing 
Excel tools and commands. There are eight 
default Tabs in the Excel Ribbon. 
 
Each Tab is divided into several Groups of 
related Excel features. If there are more 
selections for a group, there is an arrow icon at 
the lower right of the group title (e.g., Fig. 4, 
Clipboard group). Clicking on the arrow opens up 
a pane (a sub-window within the Excel window), 
or a Dialog Box, with more options (Fig. 5).  
 

Excel features and tools are selected by clicking 
the appropriate button on the Ribbon. By 
hovering the mouse pointer over a button, a brief 
description of what the button does is displayed. 
 
One (sometimes confusing) aspect of the Ribbon 
is that what each Group area displays changes 
with the width of the Excel window. If the Excel 
window – and thus the Ribbon – is not very wide, 
you may only see icons or other reduced 
descriptions  
 
The next few pages provide brief descriptions of 
each of the Tabs.
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2.3  Home Tab 
 
The Home Tab (Fig. 4) includes the most commonly used Excel features, which are listed in Table 1. 
 

 
Fig. 4. The Home Tab (Excel 365). 

 
Table 1. Home Tab Features and Tools. 

Clipboard Cut/Copy/Paste features. 
 The arrow under Paste will open up a drop-down menu.   
 The arrow to the right of “Clipboard” will open the Clipboard Pane. The Clipboard 

is a temporary folder where copied text, images, etc., are stored. 
Font 
     (Fig. 5a) 

Apply font Family, Style, Size, Bold/Italic/Underline, Color, etc.  The pop-up window 
also provides access to other cell-formatting features (Borders, Fill, etc.). 

Alignment Align content of cell: top/middle/bottom; text direction; left/center/right justify; indents. 

  Text Wrapping allows cell to automatically create more than one line of 
text, if necessary (the cell height grows with the content). 

  Merge Cell combines two or more cells into one. 
Number 
     (Fig. 5b) 

Formats how a number is represented.  Number of decimal places, Scientific Notation, 
Currency (with or without $-sign), Percent, Phone Number, Special Format (e.g., 
place a “10/” in front of the numerical date to represent “October #”), etc. 

Styles Apply Conditional Formatting (e.g., change cell color if its content is a certain value). 
Format as a Table: a Table allows easier sorting and manipulation of data. 
Cell Styles (cell color, number style), etc. 

Cells 
 

Insert/Delete/Format individual cells, rows, columns, range, etc. 

Editing 
  Fill Cells with active cell’s (cells’) formula, number, etc. 

  Clear contents of cell (including its formatting). 
Sort and Filter:  Sort and filter data. 

Ideas Provides ideas of what your can do with your spreadsheet in its current form. 

 

 

Fig. 5a. Format Cells dialog box: Font (Excel 365). 

 

 

Fig. 5b. Format Cells dialog box: Number (Excel 
365). 
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2.4  Insert Tab 
 
The Insert Tab (Fig. 6) includes items that are commonly inserted into an Excel worksheet. 
 

 
Fig. 6. The Insert Tab (Excel 365). 

 
 
Table 2. Insert Tab Features and Tools. 

Tables The Pivot Table tool allows you to summarize data of a large data table. 
Table: Turn a range of cells into a table, with headers.  A table is useful for sorting, 

filtering and formatting a related set of data. 
Illustrations Insert a Picture, Clip Art, Shapes, SmartArt (pre-designed flow-charts, organization 

charts, etc.) to help illustrate the spreadsheet. 
Add-ins 
 

Incorporate addition Excel or third-party apps into Excel. 

Charts 
     (Fig. 7) 

Insert a Chart (e.g., a plot, graph). 

Sparklines 
 

Insert sparklines – small charts within single cells 

Filters 
 

Use a Slicer to filter data visually, or a Timeline to filter dates interactively. 

Links 
 

Hyperlink to a webpage, picture, or file. 

Comment Insert a comment; especially useful when sharing the Excel file. 
Text 
 

Text Boxes, Headers/Footer, WordArt, Signature Line, Objects. 

Symbols Equations and Symbols 
 

  
 

 

Fig. 7b. Insert Chart dialog box (Excel 2010) 

 

Fig. 7b. Insert Chart dialog box (Excel 365) 
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2.5  Page Layout Tab 
 
The Page Layout Tab (Fig. 8) lists common page layout tools. 
 

  
Fig. 8. The Page Layout Tab (Excel 365). 

 
 
Table 3. Page Layout Tab Features and Tools. 

Themes Set the overall look of the workbook –Color Combination, default Fonts, Effects (details 
in shapes of objects).  A Theme helps keep everything in a document consistent.  
PowerPoint is a good example of where themes are used… with a few clicks, the 
Color/Fonts/Background of the entire document can be modified.   
A company/organization might decide to use a single theme for all of their Word, 
Excel and PowerPoint documents. 

Page Setup 
     (Fig. 9) 

Margins:  Set the white space between the text boundary and the edge of the paper, 
top/bottom/left/right. 

Orientation:  Portrait/Landscape. 
Size:  Select paper size. 
Print Area:  Select/De-select range in worksheet that you want to print. 
Breaks:  Insert/Remove Page Breaks. 
Background:  Insert a background picture into the worksheet. 
Print Titles:  Allows you to set rows in a worksheet (e.g., table headers) that will be 

printed at the top of every page, even when more than one page is printed. 
Scale to Fit 
 

Specifies size of printed output (number of pages wide, tall, scaling, etc.). 

Sheet Options 
 

View on Screen/Print Gridlines (gray borders around cells). 
View/Print Headings (columns/row headings). 

Arrange 
 

Order, Align, Rotate, etc., objects. 

 
 

  
Fig. 9. Page Setup dialog box (Excel 2010, same 

for 365). 
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2.6  Formulas Tab 
 

The Formulas Tab (Fig. 10) includes tools used to perform and check calculations. 
 

 
Fig. 10. The Formulas Tab (Excel 365). 

 
  
Table 4. Formulas Tab Features and Tools. 

Function Library While you can type formulas directly into the Formula Bar, it is often convenient to 
use the Function Library to find and select a function.   
 Insert Function will give you access to all functions.  Functions are also grouped 

by type (e.g., Financial, Logical, Math & Trig).   
 More Functions includes Statistical and common Engineering functions. 

Defined Names 
 

A cell or a range of cells can be given a name; e.g., a cell containing the number 9.81 
might be named “gravity”. Any formula in the worksheet with gravity in it will use 
the value from the cell named gravity. This makes referencing cells easier since the 
letter/number cell address need not be remembered. 

Name Manager lists all the named cells and ranges. 
Formula 

Auditing 
 

This group shows the links between cells and provides formula checking. 
 Trace Precedents:  Arrows are drawn to the active cell from cells (precedents) 

that contribute to the active cell’s value. 
 Trace Dependents:  Arrows are drawn from the active cell to cells (dependents) 

that are based on the value of the active cell. 
 Show Formulas (button to the right of Trace Precedents): 

The formulas in each cell are displayed (by default, the calculated values of 
each cell are displayed). 

 Error Checking:  Checks for common errors in formulas. 
 Evaluate Formula:  Allows trouble-shooting/debugging of a formula; opens a 

dialog box to evaluate individual parts of a cell’s formula. 
 Watch Window:  Opens a small window that displays the value (and formula) of 

cells of interest.  This is a very helpful tool; in a large worksheet, you can 
watch a particular cell’s value as you work/make changes elsewhere on the 
worksheet. 

Calculation 
 

Calculation Options:  Specify to automatically calculate or manually calculate the 
worksheet after a change in a cell value. 

Calculate Now:  Calculates entire workbook – all worksheets (in manual calculation 
mode) 

Calculate Sheet:  Calculates current worksheet only (manual calculation mode) 
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2.7  Data Tab 
 
The Data Tab (Fig. 11) allows you to import and manipulate data. 
 

 
 

Fig. 11. The Data Tab (Excel 365). 
 
Table 5. Data Tab Features and Tools. 

Get and 
Transform 
Data 

Acquire data from other programs, the web, from text files or other databases.   
Large amounts of data are effectively stored in text (.txt) files or comma separated 
values (.csv) files. Storing large amounts of raw data in an Excel file creates a very 
large file because formulas, formatting and other instructions require a lot of 
memory. 

Queries and 
Connections 

Data can reside outside the Excel file, and be accessed/linked so that data is available 
to Excel.  Changes in the external file/database will be reflected in the Excel file. 

Data Types 
 

Acquire stock and geographic data via internet. 

Sort and Filter 
 

Simple Sort:  Sorts selection from lowest to smallest or highest to lowest.  Based on 
value (number or text) in first column of selection.  Cells in each row of a selection 
stay together. 

Sort:  Opens a dialog box for advanced sorting options (e.g., multiple sort categories). 
Filters: Reduce the amount of data displayed so you can focus on certain records (e.g., 

sort out day/temperature data for all days where the temperature was greater than 
85 degrees; sort out students with a score of 75% or more). 

Data Tools 
 

Text to Columns:  Breaks text up between columns.  E.g., a column of cells might 
contain both first and last names.  In databases, it is best to break first and last 
name data into two columns. 

Remove Duplicates:  Removes records (row data) that are duplicate. 
Data Validation:  Prevents invalid data from being entered into a cell (e.g., makes sure 

an entered number is a phone number, a non-negative value, etc). 
Consolidate:  Combine values from two or more ranges into a new range. 

Forecast What-If Analysis:  Compare results of various scenarios. 
Goal Seek:  Specify the desired value of one cell by changing the value of another cell; 

this is a basic “solver” application. 
Forecast Sheet: Predict future data based on trend of worksheet data. 

Outline 
 

Group/Ungroup a range of cells so they can be expanded/collapsed/ hidden at once. 
Subtotal:  Automatically sub-total/totals items; inserts rows with subtotal. 

Analysis   
(enabled with 
Add-Ins) 

 

Add-Ins are advanced tools that need to be activated in Excel via the FILE Tab/ 
Options/ Add-Ins (Fig. 12).  Data Add-Ins are added to the Data Tab.  Two common 
Add-Ins for science and engineering are: 

 Analysis ToolPak:  Statistical and Engineering Analysis. 
 Solver:  Used to solve systems of equations and perform optimization. 
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Fig. 12. Add-In Dialog Box (Excel 365). 

 

 
 
 
 

2.8  Review Tab 
 
The Review Tab (Fig. 13) allows you to proof, review, comment, share and protect the workbook. 
 
 

 
Fig. 13. The Review Tab (Excel 2010). 

 
 
Table 6. Review Tab Features and Tools. 

Proofing Spell-checking and other grammar/language tools. 
Accessibility Helps you design your spreadsheet for those with disabilities. 
Insights Learn more about the text you select (links to internet)  
Translate Translate selected text into another language. 
Comments Allows another person to include comments (somewhat like a Post-It™ note). 
Notes At a note to the worksheet (somewhat like a Post-It™ note). 
Protect Protect Sheet/Workbook:  Prevent changes from being made to a file except by 

authorized users.   
Share Workbook:  Work with others on a network server. 
Protect and Share:  Share file, but with a password. 
Allow others to Edit Ranges.  Partially protected file. 
Track Changes:  Record changes made to file. 

Hide Ink Hides inked comments/markings (does not delete them). 
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2.9  View Tab 
 
The View Tab (Fig. 14) allows you to select how the workbook will be displayed on screen, and how it 
will be printed. 
 

 

Fig. 14. The View Tab (Excel 365). 
 
 
Table 7:  View Tab Features and Tools. 

Workbook Views Normal:  Shows workbook without page breaks. 
Page Layout:  Worksheets displayed on electronic “pages” as they will be printed. 
Page Break Preview: Heavy Solid Blue lines indicate the region of the worksheet that 

will be printed.  Heavy Dotted Blue Lines indicate page breaks.  These boundaries 
can be moved using the cursor (CLICK-AND-DRAG). 

Full Screen:  Expands Workbook to fill screen. 
Show 
 

Show and Hide Rulers, Gridlines (the gray cell-boundaries), the Message Bar, the 
Formula Bar, the Column and Row Headings, etc. 
 

Zoom Custom Zoom, 100% zoom, or Zoom to the Selection of cells. 
 

Window 
 

New Window:  Opens another Workbook in the overall Excel window. 
Arrange All:  Arranges windows horizontally, vertically, in cascade, etc. 
Freeze Panes:  Freezes a set of rows or columns on the worksheet while rest of 

worksheet can be scrolled through. This is very useful as text headings in a large 
table will always be on-screen. 

Split:  Splits worksheet into 4 panes so you can view various parts of the sheet at once. 
Hide:  Hides the current workbook. 
Unhide:  Display a hidden workbook. 
View Side by Side:  View two workbooks side-by-side or top-to-bottom (depending on 

selection in Arrange All). 
Synchronous Scrolling:  Scroll in two workbooks at once! 
Reset Window Position:  Resets the size of two workbooks being compared so that they 

are the same size (zoom) and aligned. 
Save Workspace:  Saves layouts of workbook windows. 
Switch Windows:  Switches active workbook. 

Macros 
 

Macros are a set of recorded actions/commands that you wish to save and repeat over 
and over.  If you use the same long custom formula again and again, a macro may 
save time. 

 
 
 
 

2.10  Other Tabs 
 
Other Tabs may appear on the Ribbon from time 
to time. These tabs are specific to the current 
mode. For example, when working with objects 
and figures, a Drawing Tools/Format Tab 
appears. 
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3.0  Formulas 

 
Formulas, Operators, References and Functions 

 

 
A powerful feature of Excel is that it can perform 
many mathematical operations at once, and 
continuously update results whenever the 
contents of one cell (used to calculate other 
values) changes.  
 
 
 
 

3.1  Formulas 
 
A formula is a mathematical expression that 
defines the value of a cell. Formulas can consist 
of referenced cells (precedents), numerical data, 
mathematical operators, and functions. 
 
Formulas always begin with an equal sign. 
The value of a cell with a formula is based on the 
values of other cells that the formula references, 
e.g.; if in cell C3, you type: 
 

 = C1 + C2  
 

then the value of cell C3 is the sum of the 
contents of C1 and C2. 
 
If you neglect to enter the equal sign: 
 

 C1 + C2  
 

then the content of C3 is considered to be text. No 
calculation can be performed if the referenced 
cell has a text value. 
 
 
 

3.2  Mathematical Operators 
 
The standard mathematical operators are 
available: 

 
Addition:  = C1 + C2  
 add content of C1 to content 

of  C2 
 
Subtraction:  = D7 – B6  
 subtract B6 from D7 
 
Multiplication:  = E5*E4  
 multiply E5 by E4 

  = A5*3  
 multiply A5 by 3 (Fig. 1) 
 
Division:  = E7/E2  
 divide E7 by E2 
 
Exponent:  = E7^2  

E72 : E7 squared 
  = E7^D2  

E7D2: E7 to the power of the 
value in D2 

 
The order in which operations are done is as 
follows: 
 

1. Parenthesis (inner to outer), 
2. Exponent,  
3. Multiplication and Division (left to right),  
4. Addition and Subtraction (left to right). 

 
This is the standard mathematical order of 
operations. You might recall the pneumonic 
PEMDAS (“Please Excuse My Dear Aunt Sally”). 
Note that Multiplication and Division have the 
same rank, as do Addition as Subtraction; one is 
simply the “opposite” of the other. 
 
Be careful when entering a formula. If you want 
to divide E3 by the sum of E1 and E2, enter: 
 

= E3 / (E1 + E2) 
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which tells Excel to add E1 and E2 first, then do 
the division. An incorrect formula would be: 

 
= E3 / E1 + E2 

 
which actually equals (E3/E1) + E2. 
 
 
 

3.3  Parentheses 
 
Parentheses group parts of a formula. Every left 
parenthesis must have a right parenthesis 
(Excel will give an error message if you do not 
have matching pairs). Make sure parentheses are 
in the right locations, for how they are nested is 
important in determining the order in which 
calculations are done; e.g.:  
 

= B7+C3*D4    
 
does not equal: 
 

= (B7+C3)*D4 
 
Excel provides some useful tools to help with 
parentheses. In the Formula Bar, when the right 
parenthesis of a pair is typed, the two 
parentheses marks temporarily boldface (flash). 
A parentheses pair also flashes when the text 
cursor is in the Formula Bar, and you use the 
Arrow Keys to move left/right over one of the 
parentheses.  
 
Nested parentheses are color-coded: black, green, 
purple, brown, light green, orange, etc., from 
outer pair to inner pair. 
 
HINT:  
At first, using parentheses can be difficult. It is 
often a good idea to break up long formulas into 
several steps or parts, placing each step in a 
separate cell (or a separate column if operating 
on data that take up several rows). Each step in 
the process can then be checked. Breaking up the 
problem makes troubleshooting errors easier for 
long formulas.  
 
HINT2:  
While I have emphasized parenthesis, it is not 
necessarily to use them for every operation. For 
example: 

= (B7+((C3*D4)*COS(E8)))  
is the same as: 

= B7+C3*D4*COS(E8) 

On the other hand, some users may find the 
“unneeded” parentheses helpful in visualizing 
the equation. 
 
 
 

3.4  Cell References 
 
3.4.1  Local References 
 
Consider typing the following into cell C3: 
 

 =C1*C2  
 
Excel actually understands the selected cell 
(C3) to be the product of the value from two 
cells above the selected cell (C1 is two above 
C3) and the value from one cell above the 
selected cell (C2 is one above C3). In other 
words, the cells used in the calculation are 
specified with respect to the C3. 
 
When a formula refers to cells with respect to the 
selected cell, the references are Local 
References. 
 
If you now copy the formula in C3 ([CTRL]-[C]) 
and paste it ([CTRL]-[V]) into another cell, say, 
F6, then the formula in F6 will be:   
 

 =F4*F5  
 
which is the product of the value from two 
cells above selected cell F6 and the value 
from one cell above F6. The local references are 
now with respect to F6. 
 
Local references are useful in many situations. 
Consider a set of data listed in cells A4, A5, A6, 
A7, A8, A9 as in Fig. 1 and Fig. 2. If each of these 
values is to be multiplied by 3, then the base 
equation can be entered in cell B4: = A4*3 (look 
at the cell the left and multiply its value by 3). 
The formula can then be copied down, as was 
actually done in Figs. 1 and 2.  
 
On the other hand, copying formulas with local 
references can cause problems if you are not 
careful. A local reference may work in the 
original cell, but not in other cells. The solution 
is often to use Absolute References. 
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3.4.2  Absolute References 
 
It is often desirable to use the same reference cell 
for one of the variables in a formula, no matter 
where you copy the formula to. Always referring 
to the same cell is an Absolute Reference. 
 
Consider that C1 holds a constant (like the 
acceleration of gravity) that is to be used in many 
cells in the spreadsheet. Consider typing into C3:  
 

 =$C$1*C2  
 

Excel now understands the selected cell (C3) to 
mean: always take the value in C1 and 
multiply it by the value from one cell above 
the selected cell (C2 is one cell above.) 
 
When copied to F6, the formula in F6 will be:  
 

 =$C$1*F5  
 

Which is the product of absolute reference C1 
and the value of the cell one above F6 (F5 is 
one cell above).  
 
The dollar-sign $ indicates an Absolute 
Reference. Wherever you copy the formula, the 
first term will always be $C$1. 
 
NOTE: You might be thinking that a “constant” – 
a value used everywhere – does not change … 
why not just type 9.81 into every equation that 
requires gravity. The answer is that the 
acceleration of gravity – although taken as a 
constant in a particular problem – may change 
value (e.g., on the moon or at higher earth 
elevations). You would have to change every 
equation with 9.81. By using an absolute 
reference, you would only need to change the 
content of a single cell.  
 
Another advantage of putting a “constant” into 
its own cell is that the user can see (and easily 
change) what value is actually being used in the 
calculations. 
 
 

3.4.3  Mixed References 
 
You may place an absolute reference on only the 
column, e.g., $C1, or on only the row, e.g., C$1. 
The part of the cell address with the $-sign is 
absolute and that without is local. For example, 
say the formula in cell C3 is: 
 

 =$C1+C2  
 
The absolute reference is only on the column of 
the first term (column C). If this formula is copied 
to F6, then the formula in F6 will be:  
 

 =$C4+F5  
 
Note the first term. The column reference is still 
C, since it is an absolute reference (always look 
in Column C). The row reference is now 4, since 
it is a local reference (look two rows above the 
current cell, which with respect to F6 is Row 4). 
 
 
3.4.4  Name References 
 
Instead of referring to a cell by its address, a cell 
can be named. If C1 contains the acceleration of 
gravity, why not name C1 “gravity”? as in 
(Fig. 15). Since the cell now has a unique name 
in the workbook, it is an absolute reference. 
Whenever gravity is used in an equation, it will 
reference the cell C1. Both of the following are 
the same:  
 

 =$C$1*C2     
 =gravity*C2  

 
To name a cell (or range of cells), SELECT the 
cell (or range), and the CLICK in the Name Box 
to the left of the Formula Bar. 
 
A range of cells can also be named. The name 
would then refer to the entire range. 
 
 

 

Fig. 15. Cell C1 is now named gravity, as shown in 
the Address Bar. 
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3.4.5 Referencing Cells in Another 
Worksheet 
 

In some situations, a value in one worksheet 
needs to be used in another worksheet in the 
same workbook. This situation arises when 
“Sheet1” and “Sheet2” should be kept “separate”, 
but an output of Sheet1 is an input of Sheet2.  
 

Consider working in Sheet2, and it is desired to 
multiply the value in C9 of Sheet1 by 2. The 
formula in the Sheet2 cell would look like: 
 

 =Sheet1!C9*2  
 
First, the sheet name is referenced, followed by 
an exclamation point, and then the cell: 
Sheet1!C9. 

3.5  Reference Operators 
 
You will often want to refer to more than one cell 
in a formula. This is accomplished by using the 
Reference Operators, as given in Table 8. 
 
The range and union operators are very 
powerful tools and a few words should be said 
about them here. 
 
A range specifies a rectangular block or array of 
cells. Range F12:H15 is a rectangular block that 

includes all cells F12 to H15, inclusive (Table 8, 
Figs. 1 and 2). A range is one or more columns 
wide, and one or more rows tall (deep). A large 
number of values can be quickly referenced using 
the range short-hand notation.  
 
The union operator allows you to create a list of 
quantities (numbers, cells, ranges), which can be 
used in various functions. 
 

 
 

Table 8. Reference Operators. 

Operator Description/Example 

: range of all cells between two reference cells, including those 
cells 

 

=SUM(F12:H15)  returns sum of contents of all cells between F12 
and H15, inclusive (see also, Figs. 1 and 2): 

F12  F13  F14  F15 
G12  G13  G14  G15 
H12  H13  H14  H15 

, union of two quantities (numbers, cells, ranges) 

 
=SUM(C1:C3, gravity, 6)  returns sum of all cells in range 

C1:C3, the cell named gravity, and the number 6. 

 
=AVERAGE(C1:C3, gravity, 6)  returns the average of all cells in 

range C1:C3, the cell named gravity, and the number 6. 
[single space] intersection of two ranges 

 

=SUM(C1:C3 A2:D4)  returns sum of all cells in both range 
C1:C3 and range A2:D4  (here only C2 + C3). 

    A2  A3  A4 
    B2  B3  B4 
C1  C2  C3  C4 
    D2  D3  D4 
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3.6  Functions 
 
Functions are predefined formulas. For 
example, if you wanted to add the values in cells 
C2, C3, C4, C5, ... C17, C18. You could type the 
formula: 

 

 
  = C2+C3+C4+C4+C5+C6+C7+C8+C9+C10+C11+C12+C13+C14+C15+C16+C17+C18  
 
However, a more efficient method would be to use 
the SUMMATION function and the range 
C2:C18. 
 

 =SUM(C2:C18)  
 
All mathematical functions require an 
argument to operate on, i.e., one or more inputs. 
Thus, a set of parentheses always follows the 
function name. The argument(s) within the 
parentheses of a mathematical function can be a 
number, a cell and/or a range.  
 
In Excel, there are a few exceptions to functions 
having an argument. For example, the value of  
(pi) is the result of a function without an 
argument: PI() . The function RAND() returns a 
random number between zero and one. The 
parentheses must follow the function name, but 
there is no argument (the argument is the null 
set). 
 
As you type a function into a cell, pop-ups appear 
that help remind you what argument(s) must be 
included in the function, which arguments are 
optional (in square brackets [ ] ), etc. 
 

Function names in Excel are somewhat intuitive 
(e.g., SUM, AVERAGE, COS). When in doubt, a 
function can often be found by SELECTING 
FORMULAS Tab/INSERT FUNCTION.  
 
The Search Tool in Help can be very useful for 
finding/learning about functions; e.g., search for 
“cosine”. The result gives the definition of the 
function (more details are given for more 
complicated functions), as well as the proper 
syntax (form) to use in creating the function:  
cos(number_in_radians). 
 
Help’s Search is also useful if you have some 
idea of what you want to do, but are not quite 
sure of the function name. For example, you 
might want to create a least squares linear fit for 
a set of data. Search for least squares to find 
related functions. 
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3.6.1  Some Common Functions 
 
A brief list of common Mathematical and Trigonometric functions is given in Table 9; a fuller list 
is given in Table 13. 
 
A brief list of Statistical functions is given in Table 10. A brief list of Conditional functions is 
given in Table 11. 
 
 
Table 9. Some Mathematical and Trigonometric Functions. 

number1 refers to a cell address (e.g., C5) with a numerical value, or an actual numerical value (e.g., 23); 
number1, number2 ...  refers to a range (e.g., B2:D6, B2:B12, etc.) or a list  (B2, B3, B4) of cells or numbers. 

Function Description/Example 
 
=SUM(number1, number2 ...) 

returns the sum of a list of arguments: number 1, number 2, 
etc. 

 
=SUM(A1:B3)  returns the sum of the contents in all cells 

between A1 and B3, inclusive (A1+A2+A3+B1+B2+B3) 

 
=SUM(A1:B3, D4, 6) returns the sum of the contents in the 

range A1:B3, in cell D4, and the number 6 
=SQRT(number1) returns the square root of number1 
=SUMSQ(number1, number2) returns the sum of the squares of a set of numbers 

=PI() 
returns the value of  to 15 digits; yes, use an empty set of 

parentheses to indicate “function”  
=LOG(number1) returns the log (base 10) of number1 
=LN(number1) returns the natural log of number1 
=EXP(number1) returns enumber1 
=DEGREES(number1) converts number1 in radians to degrees 
=RADIANS(number1) converts number1 in degrees to radians 
=SIN(number1) returns the sine of number1; number1 in radians 
=COS(number1) returns the cosine of number1; number1 in radians 
=TAN(number1) returns the tangent of number;, number1 in radians 
=ATAN(number1) returns the inverse tangent of number1; value in radians 
 
=ATAN2(number1, number2) 

returns inverse tangent of (number2/number1): number1 is 
the x-value, and number2 is the y-value. 

Note: ATAN(number1) actually has two solutions in 2 (360°), 
but Excel and your calculator only give one between −/2° 
and +/2°;  
ATAN2 specifies the angle knowing the x- and y-values. 

 
 
 
Table 10. Some Statistical Functions. 

Function Description/Example 
=AVERAGE(number1, number2...) returns the average of a list (range) of arguments 
=MEDIAN(number1, number2...) returns the median of a list (range) of arguments 
=MODE(number1, number2...) returns the mode of a list (range) of arguments 

=STDEV(number1, number2...) 
returns the standard deviation of a list (range) of 

arguments 
=MAX(number1, number2...) returns the maximum of a list (range) of arguments 
=MIN(number1, number2...) returns the minimum of a list (range) of arguments 
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Table 11. Some Conditional Functions. 

Function Description/Example 

=IF(logical_test, value_if_true, value_if_false) 
returns value_if_true or value_if_false depending on 

whether logical test is true or false 

 
=IF(B6<5, 0, “more”)  

returns 0 if B6<5, otherwise returns more 

 

Nested if example 
=IF(B6<5, “small”, IF(B6<10, “medium”, “large”)) 

returns small if B6<5, medium if B6<10, or 
large if anything else.  

Note: In this example, there are two ifs; this is a 
nested conditional function; watch out for the 
parentheses! 

=COUNTIF(number1, number2... , “value”) 
returns the number of entries in the range (or list) 

that equal the value 

 
=COUNTIF(B1:F3, “x”)  

returns the number of cells in range B1:F3 with 
text value “x” in them. 

 
=COUNTIF(A4:A20, “>3”)  

returns the number of cells in range A4:A20 
with value greater than 3. 

=COUNT(number1, number2 ...) returns the number of cells in a range that have 
numbers. 

=COUNTA(number1, number2 ...) returns the number of cells in a range that are not 
blank, including those with spaces 

Note: a cell with a space is NOT blank; a space is a 
character. To clear a cell, select it and hit 
[DELETE] or HOME Tab/EDITING/CLEAR 

=COUNTA(number1, number2 ...) returns the number of cells in a range that are blank 
(a space is not a blank). 

 
 
 
3.6.2  Comparison Operators 
 
Conditional Functions (Table 11) often require Comparison Operators (“equal to”, “greater than or 
equal to”, etc.). Comparison Operators are given in Table 12. 
 
 
Table 12. Some Comparison Operators. 

Operator Meaning/Example 
= equal to 

 
=IF(B6>=70, “Pass”, “Not Pass”)  

returns Pass if B6 is greater than or equal to 70, else returns Not Pass 
 =3=C5  returns  TRUE if C5 = 3;  returns FALSE if C5 is not equal to 3 

 =3=2+1  returns  TRUE 
<> not equal to 

 
=IF(B6<>8, 0, 1)  

if B6 does not equal 8, return 0, else return 1 
> greater than 
< less than 

>= greater than or equal to 
<= less than or equal to 
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3.6.3  Text Operators 
 
To concatenate two text values to produce a 
single value, use the ampersand, &. For example, 
if A5 contains the text Bull and A6 the text dog, 
then both of the following return Bulldog: 
 
  =“Bull”&“dog”   
  =A5 & A6   

 
However, if you simply try to add A5 and A6 (or 
Bull and dog), A5+A6, Excel returns #VALUE! 
since you are trying to perform a mathematical 
operation on non-numerical values.  
 

 
 
 
3.6.4  More Math Functions 
 
More functions are given in Table 13. Some are more useful than others; the more obscure ones are 
given to give you a taste of the many functions that Excel has. 
 
Table 13. Math and Trigonometry Functions. Do not forget the parentheses. 

ABS  returns the absolute value of a number 
ACOS  returns the arccosine of a number 
ACOSH  returns the inverse hyperbolic cosine of a number 
ASIN  returns the arcsine of a number 
ASINH  returns the inverse hyperbolic sine of a number 
ATAN  returns the arctangent of a number 
ATAN2  returns the arctangent from x- and y-coordinates 
ATANH  returns the inverse hyperbolic tangent of a 

number 
CEILING  rounds a number to the nearest integer or to the 

nearest multiple of significance 
COMBIN  returns the number of combinations for a given 

number of objects 
COS  returns the cosine of a number 
COSH  returns the hyperbolic cosine of a number 
DEGREES  converts radians to degrees 
EVEN  rounds a number up to the nearest even integer 
EXP  returns e raised to the power of a given number 
FACT  returns the factorial of a number 
FACTDOUBLE  returns the double factorial of a number 
FLOOR  rounds a number down, toward zero 
GCD  returns the greatest common divisor 
INT  rounds a number down to the nearest integer 
LCM  returns the least common multiple 
LN  returns the natural logarithm of a number 
LOG  returns the logarithm of a number to a specified base 
LOG10  returns the base-10 logarithm of a number 
MDETERM  returns the matrix determinant of an array 
MINVERSE  returns the matrix inverse of an array 
MMULT  returns the matrix product of two arrays 
MOD  returns the remainder from division 
MROUND  returns a number rounded to the desired 

multiple 
MULTINOMIAL  returns the multinomial of a set of 

numbers 
ODD  rounds a number up to the nearest odd integer 
 

PI ( )   returns the value of pi 
POWER  returns the result of a number raised to a power 
PRODUCT  multiplies its arguments 
QUOTIENT  returns the integer portion of a division 
RADIANS  converts degrees to radians 
RAND  returns a random number between 0 and 1 
RANDBETWEEN  returns a random number between the 

numbers you specify 
ROMAN  converts an Arabic numeral to Roman, as text 
ROUND  rounds a number to a specified number of digits 
ROUNDDOWN  rounds a number down, toward zero 
ROUNDUP  rounds a number up, away from zero 
SERIESSUM  returns the sum of a power series based on 

the formula 
SIGN  returns the sign of a number 
SIN  returns the sine of the given angle 
SINH  returns the hyperbolic sine of a number 
SLOPE  returns the slope of a linear curve fit of x-y data 

points 
SQRT  returns a positive square root 
SQRTPI  returns the (square root of the argument)*pi 
SUBTOTAL  returns a subtotal in a list or database 
SUM  adds its arguments 
SUMIF  adds the cells specified by a given criteria 
returns the sum of the products of corresponding array 

components (this is essentially the dot 
product) 

SUMSQ  returns the sum of the squares of the arguments 
SUMX2MY2  returns the sum of the difference of squares of 

corresponding values in two arrays 
SUMX2PY2  returns the sum of the sum of squares of 

corresponding values in two arrays 
SUMXMY2  returns the sum of squares of differences of 

corresponding values in two arrays 
TAN  returns the tangent of a number 
TANH  returns the hyperbolic tangent of a number 
TRUNC  truncates a number to an integer 
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3.7  Complex Numbers 
 
Complex numbers must be dealt with using 
special functions. If you simply enter: 
 

 =SQRT(–1)  
 
the result is: #NUM! which indicates that the 
function’s argument is an invalid number. In 
ordinary mathematics, we cannot take the 
square root of a negative number. However, 
entering: 
 

 =IMSQRT(–1)  
 

returns 6.1257422745431E-17 + i (at least on my 
computer), or essentially  0 + i.  
 
Excel represents a complex number as a text 
value. The IM-prefix must be used to let Excel 
know to convert the text representation (e.g., text 
4+3i) into the complex number. 
 
Some Complex Number Operators are given in 
Table 14.  
 
Caution: Excel is not the most effective tool to 
work with imaginary numbers. MATLAB is 
recommended. 

 
 
Table 14. Some Complex Number Functions. See more in FORMULAS/FUNCTION LIBRARY/MORE 

FUNCTIONS/ENGINEERING. You must include the IM-prefix. 

Function Description/Example 
 

=COMPLEX(real_num, i_num, [suffix]) 

the square brackets indicate the suffix is 
optional; the suffix must be in quotation 
marks.  The only practical option is “j” 
(engineers often use j as the imaginary 
number since i is for electric current). 

creates a complex number: real_num is the real 
coefficient; i_num is the imaginary coefficient, and 
suffix is the imaginary number, i or j (the suffix must be 
in lower case, in quotation marks “j”).   

 If the suffix is not included, the default is i.  
 The complex number is left-justified; Excel treats the 

quantity as text unless IM-prefixed commands are used. 

 =COMPLEX(1,0)  returns  1 

 =COMPLEX(0,1)  returns  i 

 =COMPLEX(4,3)  returns  4 + 3i 

 =COMPLEX(4,3,"j")  returns  4 + 3j 

=IMABS(comp_num) 
returns the absolute value (the magnitude) of complex 

number comp_num 
=IMABS(COMPLEX(4,3))  returns  5 

=IMAGINARY(comp_num) returns the imaginary coefficient of comp_num 

=IMARGUMENT(comp_num) returns the angle (argument) of comp_num in radians, from 
the real axis;  angle = atan(imag/real) 

=IMCONJUGATE(comp_num) returns the complex conjugate of comp_num 

=IMDIV(comp_num1, comp_num2) returns the quotient of two imaginary numbers 

=IMPRODUCT(comp_num1,comp_num2) returns the product of two or more imaginary numbers 

=IMREAL(comp_num) returns the real coefficient of comp_num 

=IMSQRT(comp_num) returns the square root of a complex  

 
=IMSQRT(-9) gives 3i 

on my computer: 1.83772268236293E−16+3i  = 0 + 3i 
=IMSUB(comp_num1, comp_num2) returns the difference of two or more imaginary numbers 

= IMSUM(comp_num1, comp_num2) 

returns the sum of two or more imaginary numbers 
Note: you cannot just add two complex numbers, e.g.: C1+C2 

since Excel would treat the complex numbers as text 
unless the IM-prefix is included. 

 
=IMSUM(COMPLEX(3,1),COMPLEX(0,1)) gives 3+2i 
=COMPLEX(3,1) + COMPLEX(0,1) gives #VALUE! 
=COMPLEX(3,1) & COMPLEX(0,1) gives 3+ii  (text)   
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3.8  Unit Conversions 
 
When converting units, it is not always necessary 
to start from scratch as Excel already knows 
many of the standard conversions.  
 
While you can convert degrees (say in cell A6) 
into radians by entering the basic equation: 
 

 =A6*(PI()/180)  

 
You can also use the RADIAN function: 
 

 =RADIANS(A6)  
 
Some Unit and Number System Conversion 
functions are given in Table 15. 

 
 
Table 15. Some Conversion Functions.  

Function Description/Example 

=DEGREES(number1) converts number1 in radians to degrees. 

=RADIANS(number1) 
converts number1 in degrees to radians; the 

argument of trig. functions in Excel must be in 
radians.  

=CONVERT(number,“from_unit”, “to_unit”) converts number of from_unit into to_unit. 

 =CONVERT(1, “in”, “mm”) returns  2.54. 

 
=CONVERT(1, “lbf”, “N”) returns  4.45 (2 dec. 
points). 

 =CONVERT(1, “mi”, “km”) returns  1.61. 

 =CONVERT(1, “hr”, “sec”) returns  3600. 

 

=DEC2BIN(number,[places]) 

square brackets indicate places is optional. 

converts a decimal (base 10) number into a 
binary (base 2) number. Optional places 
indicates the number of digits in the new system 
… this provides padding with leading zeroes. If 
places is omitted, no leading zeroes are added. 

 =DEC2BIN(15)  returns  1111 

 =DEC2BIN(15,6)  returns  001111 

=DEC2HEX(number,[places]) 
converts decimal (base 10) number into a 

hexadecimal (base 16) number 
 =DEC2HEX(15)  gives  F       (A=10, B=11 … F=15) 

=DEC2OCT(number,[places]) 
converts decimal (base 10) number into octal (base 8) 

number 

 =DEC2OCT(15)  gives  17 

In general:    
=_ _ _2_ _ _ 

    flip/combine DEC, BIN, OCT and HEX 

Various conversions between decimal, binary, octal, 
hexadecimal number systems 

=ROMAN(number, [form]) 
square brackets indicate form is optional. 

returns Roman Numeral equivalent of decimal 
number. Form (0, 1, 2, 3, 4) is optional and 
specifies the type of numeral – classic (0, 
default), or more concise (modern) versions 

 =ROMAN(26)  gives  XXVI 
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3.9  Error Messages 
 
Some common Errors that are displayed in cells are given in Table 16. 
 
 
Table 16. Error Message.  

Error Description/Example 

######## the column is not wide enough for the number  

#DIV/0! attempting to divide by zero 
 = 12/0 

#N/A 
value is not available to a function 
 =CONVERT(1, “m”, “sec”) since dimensions are not the same. 

#NAME? 
text is in the formula; and the text value is not the name of a cell (range) 
 =3*g    where g is not defined 

#NULL specifying the intersection of two areas that do not intersect gives the null set 

#NUM! invalid number value in function 
 = acos(2) 

#REF! 

cell reference is not valid; e.g., cells originally in a formula have been deleted 
For example, if cell F6 contains  =3*H4, and column H is deleted, the equation 

in F6 becomes = 3*#REF!. Even though old column I becomes new column 
H, the original cell that F6 pointed to no longer exists. 

#VALUE! 
wrong type of argument in function 
 =B8+C8 where B8 and C8 contain text quantities or complex quantities 
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Notes 
 
 
 
 
 
 
 
 
 
 
 
 
 

  
 


